I just did a fresh clone (chasing another bug).

I did ./waf configure build

Then I did cd ntpq and ./ntpq
It doesn't work.  I have to run ./waf check to build some of the python ntp 
libraries.

[murray@hgm ntpq]$ ./ntpq
ntpq: can't find Python NTP library -- check PYTHONPATH.
No module named ntp_control
[murray@hgm ntpq]$ cd ..
[murray@hgm xxxx]$ ./waf check
Waf: Entering directory `/home/murray/ntpsec/xxxx/build/main'
[117/210] Processing /home/murray/ntpsec/xxxx/pylib/ntp_control.py: 
wafhelpers/pythonize-header include/ntp_control.h -> pylib/ntp_control.py
[118/210] Processing /home/murray/ntpsec/xxxx/pylib/ntp_magic.py: 
wafhelpers/pythonize-header include/ntp.h -> pylib/ntp_magic.py
[127/210] Processing VERSION
[192/210] Processing build/main/tests/test_libntp
[193/210] Processing build/main/tests/test_ntpd
[196/210] Processing build/main/tests/test_ntpdig
[197/210] Compiling build/main/pylib/version.pyo
[206/210] Compiling build/main/pylib/ntp_control.pyc
[207/210] Compiling build/main/pylib/ntp_magic.pyo
[208/210] Compiling build/main/pylib/ntp_control.pyo
[209/210] Compiling build/main/pylib/version.pyc
[210/210] Compiling build/main/pylib/ntp_magic.pyc
Waf: Leaving directory `/home/murray/ntpsec/xxxx/build/main'
Wrote test log to:  /home/murray/ntpsec/xxxx/build/main/test.log
execution summary 
  tests that pass 2/3 
    /home/murray/ntpsec/xxxx/build/main/tests/test_ntpd 
    /home/murray/ntpsec/xxxx/build/main/tests/test_libntp 
  tests that fail 1/3 
    /home/murray/ntpsec/xxxx/build/main/tests/test_ntpdig 
'check' finished successfully (1.061s)
[murray@hgm xxxx]$ 

As far as I can see, everything above should have been run as part of build, 
and steps 192, 193, and 196 should be run again.  I just tried it.  ./waf 
check runs steps 205, 206, and 210.




-- 
These are my opinions.  I hate spam.



_______________________________________________
devel mailing list
devel@ntpsec.org
http://lists.ntpsec.org/mailman/listinfo/devel

Reply via email to