> Why all the ceremony? What people probably want is:
>
> Q_DEFAULT_PROPERTY(int, value)
>
> That would expand to:
>
>      Q_PROPERTY(int value READ value WRITE setValue NOTIFY valueChanged)
> public:
>      int value() const { return m_value; }
>      void setValue(int value)
>      ...

...which would, in my case, mean different naming schemes for DEFAULT and 
non-DEFAULT properties.
My naming scheme would mandate
getValue() const
setValue(int value);

With the current BINDABLE solution, I retain control over how to name the 
functions, and I simply omit the setter because I can directly assign to the 
member.
Generating a getter that does not follow my naming scheme is not acceptable and 
would be very confusing when using such a class.

Wild idea: Could I utilize C++26 reflection to generate the necessary getters, 
setters and signals in a way that moc could see? Unfortunately I doubt it...

Kind regards

Robert
________________________________

This message and any attachments are solely for the use of the intended 
recipients. They may contain privileged and/or confidential information or 
other information protected from disclosure. If you are not an intended 
recipient, you are hereby notified that you received this email in error and 
that any review, dissemination, distribution or copying of this email and any 
attachment is strictly prohibited. If you have received this email in error, 
please contact the sender and delete the message and any attachment from your 
system.

ANDRITZ HYDRO GmbH


Rechtsform/ Legal form: Gesellschaft mit beschränkter Haftung / Corporation

Firmensitz/ Registered seat: Wien

Firmenbuchgericht/ Court of registry: Handelsgericht Wien

Firmenbuchnummer/ Company registration: FN 61833 g

DVR: 0605077

UID-Nr.: ATU14756806


Thank You
________________________________
-- 
Development mailing list
Development@qt-project.org
https://lists.qt-project.org/listinfo/development

Reply via email to