On Wed, Sep 21, 2016 at 4:04 PM, MikeB wrote:

> The first problem is that once I boot the system and install the
> hello-world snap, then reboot, the snapd is unable to start up.  So no more
> access to snaps.
> I've had this problem before and fixed it by using the ubuntu-core from
> the regular channel rather than the edge.  However, when I leave out the
> '-c edge' from ubuntu-image, it fails trying to fetch the gadget.
> The second problem is that
> ​​
> firstboot setup fails every time.
> I see this message in the syslog...
> error: cannot create state: state "/var/lib/snapd/state.json" already
> exists
> The third problem is I see 'Failed to start Notify bootloader that boot
> was successful'.
> I see this message in the syslog...
> error: cannot downgrade: snapd is too old for the current system state
> (patch level 4)
​I used the technique described in [1] to workaround the gadget fetch
problems when working in the default channel.  This has solved my first and
third problems - snapd unable to start after rebooting after installing the
first snap.​

​The second problem - ​
firstboot setup fails every time - is still occurring.

However, a new issue has appeared - a very long bootup time.

>From 'Starting Initial cloud-init job (metadata service crawler)...' to
getting a login prompt now takes about 260 seconds.  This happens on every

About 60 seconds is spent in 'Started Update resolvconf for networkd DNS.'

Another 80 seconds is spent  "Calling ''"

Another 120 seconds is spent  "Calling 'http:///latest/meta-data/instance-id'"
- that is the default gateway for the subnet, which, as fara as I know,
does not have an http server.

Any ideas on how I can get back to reasonable boot times?

Regards, Mike

[1] https://github.com/CanonicalLtd/ubuntu-image/blob/master/docs/notes.rst
Devices mailing list
Modify settings or unsubscribe at: 

Reply via email to