On Tuesday, 14 January 2014 at 13:55:10 UTC, evilrat wrote:
On Tuesday, 14 January 2014 at 13:16:12 UTC, Alexander Bothe wrote:
On Tuesday, 14 January 2014 at 13:06:05 UTC, evilrat wrote:
gdb plugin version 0.2.5 still gives the same error.

Ah, sorry, I should've mentioned it:
There's an option panel called "Gdb.D" now where you can put in a custom gdb command.

it now starts, but in terminal started by xamarin studio it prints: &"warning: GDB: Failed to set controlling terminal: Operation not permitted\n"

Known issue, is probably unfixable.

Hello World!
in output panel:
"Couldn't inject exception handler breakpoint - no finddata symbol found!"

Could you locate the binary libphobos file, open it e.g. with SciTE and look for some mangled string that contains 'finddata', such as

- something like this is required to have proper exception hooking :)

and after clicking step through it adds:
Single stepping until exit from function _Dmain,\nwhich has no line number information.

Okay, this means dmd won't generate file/offset associations and/or thus can't be loaded in gdb.

If you tried running your D programw with gdb, made a breakpoint at _Dmain and stepped through the method's code - could you tell me whether it's actually possible to step through the lines? Or is it just telling the same? If so, we can forget about having the gdb addin on OSX as the most essential parts of debugging aren't supported (again, just as on Windows) due to mysterious reasons..

Reply via email to