On 2/22/2015 2:43 PM, Gan wrote:




dub.json:
{
     "name": "game",
     "description": "game",
     "dependencies":
     {
         "dgame": "~master"
     }
}

First, you need to change your dependency to something like this:

"dependencies":
>      {
>          "dgame": "~>0.4.0"
>      }

Or you can use ==0.4.0, or >=0.4.0. Just don't use branch-based dependencies anymore (like ~master) as those are deprecated.

Second, there's a bug in Dgame's dub.json, which is causing compilation to error out. I'll post a PR for it.

Reply via email to