On Thursday, 9 February 2017 at 17:16:35 UTC, Joseph Rushton
This package should be possible to install on Ubuntu 16.04 or
later, or Ubuntu 14.04, as well as any other distro making
available a recent version of snapd (2.21 or later):
Looks like there is a linking problem on Ubuntu 14.04 presumably
related to ABI incompatibility between the precompiled libphobos
and libdruntime and the system toolchain. I'll investigate
further and follow up on this with an appropriate fix.