Am 13.12.2017 um 00:49 schrieb Timothee Cour:
that's great... unfortunately
https://github.com/vibe-d/vibe.d/issues/1991 is a regression
preventing from updating to 0.8.X (has a reduced test case). Any help
on this would be very appreciated, thanks!


I'll have a look at this. Unfortunately serialization and @safe do not go well together due to https://issues.dlang.org/show_bug.cgi?id=16528 so that currently manual (non-generic) workarounds are required, and there may be other similar issues lurking.

For the specific code, if possible, the easiest way to sidestep the error would be to use @safe or @trusted on those property functions.

Reply via email to