On Thursday, 3 August 2017 at 20:22:56 UTC, Johnson Jones wrote:
On Thursday, 3 August 2017 at 07:06:06 UTC, Rainer Schuetze wrote:


On 31.07.2017 19:51, Johnson Jones wrote:
On Saturday, 22 July 2017 at 12:54:17 UTC, Rainer Schuetze wrote:


On 18.06.2017 20:25, Mike B Johnson wrote:
[...]

After installing VS2017 on a fresh Win10 install I could reproduce this issue: the mago debug engine failed to load the symbols when only VS2017 is installed, because the COM-CLSID to load msdia140.dll changed. Switching to the VS debug engine worked, though.

Should be fixed in the next release.

I installed a fresh VS2017 and the latest beta visual D and same issues. As of today, was this suppose to be fixed?

It hasn't been released until now: https://github.com/dlang/visuald/releases/tag/v0.45.0

Thanks! Seems to be working.

well, in x86 I still get a few BP's that won't be hit every once in a while(well, happened for the first time since I've used the new release).


The code looks like

while(i < data.length && data[i] != '>' && data[i] != '"' && data[i..i+token2.length] != token2) i++;
if (data[i] == '>') { continue; }

I put a BP on the if and when ran it says it won't be hit. I have a BP right above it and below it and it works fine.

says "The BP will not currently be hit. No symbols have been loaded for this document.". I do not know why symbols really matter for BP's?


If I change the if statement to

                        if (data[i] == '>')
                        {
                                continue;
                        }

it works ;/

Reply via email to