On 4/30/14, 11:53 AM, monarch_dodra wrote:
On Wednesday, 30 April 2014 at 15:54:42 UTC, bearophile wrote:
We've resisted named unittests but I think there's enough
evidence to make the change.

Yes, the optional name for unittests is an improvement:

unittest {}
unittest foo {}

I am very glad your coworker find such usability problems :-)

If we do "name" the unittests, then can we name them with strings? No
need to polute namespace with ugly symbols. Also:

//----
unittest "Sort: Non-Lvalue RA range" { ... }
//----
vs
//----
unittest SortNonLvalueRARange { ... }
//----

I'd argue for regular identifiers instead of strings - they can be seen in stack traces, accessed with __FUNCTION__ etc. -- Andrei

Reply via email to