On Friday, 14 October 2016 at 04:44:46 UTC, Patrick Schluter wrote:
On Thursday, 13 October 2016 at 23:15:00 UTC, David Gileadi wrote:
On 10/13/16 12:52 PM, Stefan Koch wrote:
On Thursday, 13 October 2016 at 19:49:42 UTC, Johan Engelen wrote:
On Thursday, 13 October 2016 at 19:35:08 UTC, Stefan Koch wrote:

Please share your thoughts and tell me what other intrinsic functions
could/should be added.

I think the name should be different from "intrinsics", so that it can also contain functions like "likely-functionptr" / "likely-class" optimization functions (e.g. the is_likely template from the other


What name would you suggest then ?

As an ignorant bystander I like core.intrinsics, but if not then perhaps core.compilerhints or something to that effect?


short and simple

but core.intrinsics would have the advantage that it can be used to put other intrinsics that are not specifically compiler hints (like __builtin___clear_cache from gcc for example).

Reply via email to