On 20 February 2012 01:10, kennytm <[email protected]> wrote:

> Manu <[email protected]> wrote:
> > I propose size_t + ssize_t should both exist, and represent the native
> > integer size.
>
> sizediff_t (currently just aliased to ptrdiff_t but the link could be
> broken).
>
> > Also something like ptr_t, and ptrdiff_t should also exist,
> > and represent the size of the pointer.
> >
>
> core.stdc.stdint.uintptr_t
>

O_o .. how is this different to size_t now? Why the redundant alias?

Reply via email to