You need a better compiler for ObjC.

If you follow these instructions 

it works perfectly ok on Debian 9 using the Debian provided clang 3.8 or 3.9.  
I also built a package with llvm/clang/lldb 5.0 for debian which is in my repo. 
Especially lldb sucks under Linux. The version 5.0 sucks a bit less but its 
still missing the macros which I know from OS X (such as "po" for print 
object). For some reasons I can't even print NSStrings properly in the 
debugger. Apparently Apple has some magic scripts for LLDB which the generic 
version doesn't have (does anyone happen to know?).

If you want to use llvm 5.0 from my repo:

        echo "deb stretch universalss7" > 
        wget 4 -O - |apt-key add -
        apt-get update
        apt-get install llvm-clang-lldb

        (or more specifically

The same repo also has prebuilt gnustep-make,-base,-gui,-back, -corebase builds 
built exactly on these instructions (and installs to /usr/local) So if you do 
apt-get install gnustep-bundle you get them pulled in including all 

> On 4 Feb 2018, at 20:24, Svetlana Tkachenko <> wrote:
> Hello All,
> Yavor Doganov wrote:
>>> Now gnustep-base says objc headers are missing, what package is that
>>> in Debian? I already tried objc*dev but the error remains.
>> What are you trying to do?  You must have an Objective-C compiler and
>> runtime before configuring GNUstep Make.  You build the compiler and
>> the runtime first, then Make, Base, Gui, Back and the rest of the
>> GNUstep world.  GNUstep Base has a configure check to detect if
>> there's a mismatch between its own and gnustep-make's configuration.
>> If you have gobjc/gobjc-7 installed, you already have the GNU
>> Objective-C runtime headers (libobjc-7-dev).  If you intend to use
>> Clang and the GNUstep runtime, you have to remove gobjc, install clang
>> as a debian package (or build it manually if you wish) and
>> build/install the GNUstep runtime before configuring GNUstep make.
>> There is no Debian package for the GNUstep runtime (aka libobjc2).
> I compiled GNUstep Make.
> Then I tried to compile GNUstep Base.
> It says this:
> Ivan Vučica wrote:
>> You didn’t say anything about how the env vars were in your environment 
>> after a reboot?
>> Did you check if they are there using the “env” command? Did you find out 
>> what left them there and cleaned that thing away?
> 'env|grep GNUSTEP' says...
> svetlana@debians:~$ env|grep GNUSTEP # I do not know what makes this
> GNUSTEP_USER_ROOT=/home/svetlana/GNUstep
> svetlana@debians:~$ source /usr/local/share/GNUstep/Makefiles/ # 
> this was made by GNUstep Make that I compiled
> svetlana@debians:~$ env|grep GNUSTEP
> GNUSTEP_MAKEFILES=/usr/local/share/GNUstep/Makefiles
> svetlana@debians:~$ 
> -- Sveta
> _______________________________________________
> Discuss-gnustep mailing list

Discuss-gnustep mailing list

Reply via email to