David Cramer wrote:
> IMO show() and hide() are extremely ugly. And I think .values() is becoming
> ugly with the addition of values_tuple or whatever it's called. I don't see
> a real good reason to clutter the namespace even more than it already is.
> I'd rather have .values(type=dict) or something similar.
Sorry, for some reason I completely skipped over the type switching in
the values() call. I do agree that it would be better than having
separate methods for each.
I wonder if we would also need to support the people who want to exclude
fields:
Model.objects.values('field1', 'field2', exclude_fields=[...], type=...)
Has a discussion of something like the "type" keyword argument been
brought up before? The only two threads [1][2] I found about
valuelist() and value_list() don't mention the idea.
Gary
[1]
http://groups.google.com/group/django-developers/browse_frm/thread/22b44f4eafaf956a/
[2]
http://groups.google.com/group/django-developers/browse_frm/thread/4c7ba291577e6e73/
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"Django developers" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/django-developers?hl=en
-~----------~----~----~----~------~----~------~--~---