On Sat, Sep 20, 2008 at 2:47 AM, HenrikV <[EMAIL PROTECTED]> wrote:
>
> If you imagine changing the table name of the auth.User table to
> 'account_user'. Should the groups relationship create a table called
> 'account_user_groups' or 'auth_user_groups' ?

I'm unclear if this is a user 'how to' question, or a badly phrased
suggestion for an improvement to Django.

If it's a user question, it should be asked on django-users.
django-developers is for discussing the development of django itself.
That said - unless overridden with the db_table setting or the use of
a through model, the m2m table name will be "model.db_table +
field_name" - in your case, that means account_user_groups.

If this is a suggestion for an improvement to Django, can you clarify
what exactly you are proposing? The current m2m table naming scheme
has been in place since the very beginning, and with the exception of
a few customizations, it hasn't changed in all that time. Why do you
think it is necessary to change the naming scheme?

Yours,
Russ Magee %-)

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Django developers" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/django-developers?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to