#25877: Consider refactoring AdminSite.check_dependencies
------------------------------------------------+------------------------
Reporter: aaugustin | Owner: nobody
Type: Cleanup/optimization | Status: new
Component: contrib.admin | Version: master
Severity: Normal | Keywords:
Triage Stage: Unreviewed | Has patch: 0
Needs documentation: 0 | Needs tests: 0
Patch needs improvement: 0 | Easy pickings: 1
UI/UX: 0 |
------------------------------------------------+------------------------
I see two problems with this method:
1. It doesn't take advantage of the checks framework. Perhaps it should?
2. It runs as a side effect of loading the admin URLs. If it must run when
Django starts it should be called from AdminAppConfig.ready() instead.
--
Ticket URL: <https://code.djangoproject.com/ticket/25877>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/052.f13f27de68d2e53b7ea97f70e41e5c86%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.