Hello people,
        I'm writing on this ML about this issue I've had with cacti before
I'll be able to edit https://git.devuan.org/devuan-packages (if
ever :-).
  The version of Cacti that ships with Jessie (0.8.8b) just wouldn't talk
(or listen) to the SNMP agent.  There is nothing wrong with the SNMP agent,
as snmpget and snmpwalk work just fine from the command line.  However, if on
cacti's web interface I set "Downed Device Detection" to "SNMP Uptime" it
would always report "Status - Down".  Uptime detection does not involve the
DB and Apache/PHP do not show any malfuction, so the problem must lay with
Cacti itself.  As I have a Fedora 24 available, I tried the same
configuration on that machine.  It worked just fine.

Devuan 1.0 Jessie installs:
ii  cacti          0.8.8b+dfsg- all          web interface for graphing of mon

Fedora 24 installs:
cacti-0.8.8h-1.fc24.noarch

  Log file /var/log/cacti/cacti.log reports:

11/30/2016 04:55:03 PM - CMDPHP: Poller[0] WARNING: SNMP Get Timeout for
Host:'localhost', and OID:'.1.3.6.1.2.1.1.3.0' 11/30/2016 04:55:03 PM -
CMDPHP: Poller[0] Host[1] SNMP: Host did not respond to SNMP

  And yet:

[alessandro@wrkstn03 ~]$ snmpget -v 2c -c "$ROCOMMUNITY"
localhost .1.3.6.1.2.1.1.3.0
iso.3.6.1.2.1.1.3.0 = Timeticks: (122187)
[alessandro@wrkstn03 ~]$ 

_______________________________________________
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng

Reply via email to