avconv crashes while building a video from an image and audio.  It
  worked until a recent update.

(I'll also hang out on IRC in case people need me live.)


I am using


According to `apt-cache show libav-tools` I have


I am trying to do a command like:

\rm  --force  output.mp4
\avconv  \
  -loop 1 \
  -i "image.jpg" \
  -i "audio.ogg" \
  -shortest \
  -acodec copy \
  -c:v:1 libx264 \
  -profile:v high \
  -r 1 \

When running the above and appending `2> foo.txt` I get:

- The error seems to happen at different times under the same
  conditions, though I have not done specific testing to confirm this.
- I have tried variations of the above command, with no luck.
- I have tried different audio and images, with no luck.


I have tried to downgrade:

  apt-cache showpkg libav-tools

I see:


.. I didn't take very good notes at this point, but I think I did
something like:

  apt-get install libav-tools-6:11.11-1~deb8u1
  apt-mark hold libav-tools


I have tried fetching the dependency chain from an old version of
Debian, but that was a nightmare that ultimately didn't work out.


I have.. tried installing Debian-proper, but good god damn its disk
access is busted.  A bad scheduler?  Well it serves me right.


According to old notes, this version worked:


.. however, I do not know if a more recent version worked before I
noticed this problem.


My other thoughts are:

- Install devuan_ascii_2.0.0_beta_i386_desktop-live
- Install beta packages, if I can be directed to them.
- Vary the script and re-test as needed.
- Prepare and host this script and specific images and audio so this
  can be tested by others.
- Try to use a different video codec.
    --  x265 seems to be missing
    --  I don't really understand any of this.  Building the command I'm
    currently using was trial-and-error from some searching.

Dng mailing list

Reply via email to