Perhaps run

smartctl  -C /dev/sd<X> -a

to see how long an extended check might take, plan to leave PC on for a
little over this time and run an extended test:

smartctl -t long /dev/sd<X>

monitor status with

smartctl  -l selftest /dev/sd<X>

PS, longest serving disk in my RAID: 61068 hours.... has no pending
sectors or re-allocations.



On 15/04/18 10:08, PeterMerchant via dorset wrote:
> Got it sorted!  I used UBCD (Ultimate Boot CD) and it's copy of
> Gparted to  attempt a recover of the disc, which showed me that it had
> been a Windows system. I was then able to format the whole disk as NTFS.
>
> For some reason it had not wanted to know Ubuntu, but now I was able
> to install Fedora 27 (KDE) which is up and  running. Yesterday once I
> got it into a state where the head was continuously seeking back and
> forth (You know that sound when you hear it).
>
> This morning I was unable to run fsck on it because of something to do
> with LVM, but  UBCD has a disk test facility that I have run. Yes
> there are some faults on the disk, and some parts that are
> 'pre-failure', but it shows that it has had 19000 hours of use.
>
> Conclusion: Success, and the disk will be OK for play, but don't be
> surprised if it continues to degrade.
>
> Cheers,
> Peter
>
> On 05/04/18 19:41, Hamish MB wrote:
>> Sounds perplexing...
>>
>> You could try gparted's create partition table option (in one of the
>> menus).
>>
>> Beyond that, maybe it's better to give up if its being that much of a
>> pain - it may just be broken.
>>
>> Hamish
>>
>>
>> On 05/04/18 17:46, PeterMerchant via dorset wrote:
>>> I was given an old Dell with a 250GB MAxtor SATA disk that couldn't be
>>> found by the live disks that I tried. Eventually I loaded up a rescue
>>> disk and gparted and discovered that the disk had an invalid
>>> partition. I was unable to format it as Ext2, 3 or 4, But I did format
>>> it as 2 FAT32 partitions and then it was recognised in my other
>>> computer. I have tried again to get it to format as Ext-x with no
>>> luck. It now does have a swap partition. It didn't like having the
>>> jumper in for the CLJ (cylinder Limitation jumper)
>>>
>>> Any thoughts on how I can possibly resurrect this disk, or should I
>>> not waste my time?
>>>
>>> Thanks,
>>>
>>> Peter
>>>
>>>
>
>


-- 
Next meeting:  Bournemouth, Tuesday, 2018-05-01 20:00
Meets, Mailing list, IRC, LinkedIn, ...  http://dorset.lug.org.uk/
New thread:  mailto:dorset@mailman.lug.org.uk / CHECK IF YOU'RE REPLYING
Reporting bugs well:  http://goo.gl/4Xue     / TO THE LIST OR THE AUTHOR

Reply via email to