Hi all,

This is regarding the recent hdcp content type patch that was merged into 
drm-misc. (https://patchwork.freedesktop.org/patch/320958/?series=57233&rev=11)

There are displays on the market that advertise HDCP 2.2 support and will pass 
authentication and encryption but will then show a corrupted/blue/black screen 
(the driver cannot detect this). These displays work with HDCP 1.4 without any 
issues. Due to the large number of HDCP-supporting devices on the market we 
might not be able to catch them with a blacklist.

From the user modes perspective, HDCP1.4 and HDCP2.2 Type0 are the same thing. 
Meaning that this interface doesn't allow us to force the hdcp version. Due to 
the problems mentioned above we might want to expose the ability for a user to 
force an HDCP downgrade to a certain level (e.g. 1.4) in case they experience 
problems.

What are your thoughts? and what would be a good way to deal with it?


Thanks,

Bhawan
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to