On Thu Jun 19, 2025 at 4:24 AM JST, Benno Lossin wrote: > On Mon Jun 16, 2025 at 8:41 AM CEST, Alexandre Courbot wrote: >> On Sun Jun 15, 2025 at 4:16 AM JST, Benno Lossin wrote: >>> On Thu Jun 12, 2025 at 4:01 PM CEST, Alexandre Courbot wrote: >>>> + #[inline(always)] >>>> + pub const fn [<fls_ $t>](v: $t) -> u32 { >>> >>> Can we name this `find_last_set_bit_ $t`? When the upstream function >>> lands, we should also rename this one. >> >> We can - but as for `align_up`/`next_multiple_of`, I am not sure which >> naming scheme (kernel-like or closer to Rust conventions) is favored in >> such cases, and so far it seems to come down to personal preference. I >> tend to think that staying close to kernel conventions make it easier to >> understand when a function is the equivalent of a C one, but whichever >> policy we adopt it would be nice to codify it somewhere (apologies if it >> is already and I missed it). > > I don't think we have it written down anywhere. I don't think that we > should have a global rule for this. Certain things are more in the > purview of the kernel and others are more on the Rust side. > > My opinion is that this, since it will hopefully be in `core` at some > point, should go with the Rust naming.
I guess in that case we should go with `last_set_bit`, as `find_` is not really used as a prefix for this kind of operations (e.g. `leading_zeros` and friends).