Thank you for your contribution! Sashiko AI review found 1 potential issue(s) 
to consider:
- [Low] A comment in the macro implementation still refers to the old macro 
name `ForLt!`.
--

commit c45f7e371456a82ca15ef60543a42d6b7346219f
Author: Danilo Krummrich <[email protected]>

rust: types: rename ForLt to CovariantForLt

Rename ForLt to CovariantForLt to prepare for the introduction of a new
ForLt base trait that does not require covariance.

[ ... ]

> diff --git a/rust/macros/for_lt.rs b/rust/macros/for_lt.rs
> index 364d4113cd107..e1233701d6ccf 100644
> --- a/rust/macros/for_lt.rs
> +++ b/rust/macros/for_lt.rs
> @@ -176,7 +176,7 @@ fn prove(&mut self, ty: &'a Type) {
>      }
>  }
>  
> -pub(crate) fn for_lt(input: HigherRankedType) -> TokenStream {
> +pub(crate) fn covariant_for_lt(input: HigherRankedType) -> TokenStream {

[Severity: Low]
Does the inline comment in Prover::prove() earlier in this file also need
to be updated?

It currently explains why certain reference lifetimes are deferred to the
compiler by citing the old macro name:

    // This is to block cases like ForLt!(for<'a> &'static &'a u32), as the
    // presence of the type implies 'a: 'static but this is unsound.

Could this comment be updated to refer to CovariantForLt! instead, to match
the macro rename introduced here?

[ ... ]

-- 
Sashiko AI review ยท 
https://sashiko.dev/#/patchset/[email protected]?part=1

Reply via email to