On Fri Jun 19, 2026 at 8:08 AM JST, Danilo Krummrich wrote: > Rename ForLt to CovariantForLt to prepare for the introduction of a new > ForLt base trait that does not require covariance. > > The existing ForLt trait requires covariance, which enables the safe > cast_ref() method. This rename preserves the same semantics under a more > precise name, making room for a weaker ForLt trait in a subsequent > commit. > > No functional change. > > Signed-off-by: Danilo Krummrich <[email protected]>
With the Sashiko comment addressed, Reviewed-by: Alexandre Courbot <[email protected]> (I am also looking at the rest of the series, as well as its DRM follow-up, but need to let my brain soak into them some more to grok all the details)
