On 2026-07-01 11:12 a.m., Matt Evans wrote: > Preparing for a refactor in a subsequent patch, split the pool-related > release code into a new pci_p2pdma_release_pool() function. > > This allows future compile-time selection of a null implementation for > pci_p2pdma_release_pool(), when p2pdma.c is refactored into core- and > P2P-related files. > > Signed-off-by: Matt Evans <[email protected]> Looks correct to me, thanks! Reviewed-by: Logan Gunthorpe <[email protected]>
- [PATCH v4 00/10] vfio/pci: Add mmap() for DMABUFs Matt Evans
- [PATCH v4 01/10] PCI/P2PDMA: Split pool-related clean... Matt Evans
- Re: [PATCH v4 01/10] PCI/P2PDMA: Split pool-relat... Bjorn Helgaas
- Re: [PATCH v4 01/10] PCI/P2PDMA: Split pool-relat... Logan Gunthorpe
- [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CO... Matt Evans
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P... Bjorn Helgaas
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P... Logan Gunthorpe
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_P... Matt Evans
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONF... Logan Gunthorpe
- [PATCH v4 03/10] vfio/pci: Add a helper to look up PF... Matt Evans
- [PATCH v4 04/10] vfio/pci: Add a helper to create a D... Matt Evans
- [PATCH v4 05/10] vfio/pci: Convert BAR mmap() to use ... Matt Evans
- [PATCH v4 07/10] vfio/pci: Clean up BAR zap and revoc... Matt Evans
- [PATCH v4 08/10] vfio/pci: Support mmap() of a VFIO D... Matt Evans
