On 2026-07-02 10:44 a.m., Matt Evans wrote: >> So maybe at this point it's fine to enable this on 32bit systems and we >> can remove this requirement. However, I think we should do that >> explicitly in its own patch, not hide it in this refactoring patch. > > Your question does prove it's too stealthy as-is. :) PCI_P2PDMA still > can't be enabled on 32-bit systems because of its ZONE_DEVICE -> > MEMORY_HOTPLUG -> 64BIT dependency. So we're not enabling 32-bit > support for PCI_P2PDMA here, but it's not obvious and so I'll re-add the > `depends on 64BIT`. At least then it won't be enabled without intention > if someone enables ZONE_DEVICE on 32-bit systems... Ok, that all makes sense to me. I would be good with removing the 64BIT dependency (as it is is a bit confusing as is) but I think adding another patch would be appropriate with some of the commit message notes you mentioned in your emails. Besides that, I think you can add to this patch: Reviewed-by: Logan Gunthorpe <[email protected]> Thanks, Logan
- [PATCH v4 00/10] vfio/pci: Add mmap() for DMABUFs Matt Evans
- [PATCH v4 01/10] PCI/P2PDMA: Split pool-related clean... Matt Evans
- Re: [PATCH v4 01/10] PCI/P2PDMA: Split pool-relat... Bjorn Helgaas
- Re: [PATCH v4 01/10] PCI/P2PDMA: Split pool-relat... Logan Gunthorpe
- [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CO... Matt Evans
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P... Bjorn Helgaas
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P... Logan Gunthorpe
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_P... Matt Evans
- Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONF... Logan Gunthorpe
- [PATCH v4 03/10] vfio/pci: Add a helper to look up PF... Matt Evans
- [PATCH v4 04/10] vfio/pci: Add a helper to create a D... Matt Evans
- [PATCH v4 05/10] vfio/pci: Convert BAR mmap() to use ... Matt Evans
- [PATCH v4 07/10] vfio/pci: Clean up BAR zap and revoc... Matt Evans
- [PATCH v4 08/10] vfio/pci: Support mmap() of a VFIO D... Matt Evans
- [PATCH v4 06/10] vfio/pci: Provide a user-facing name... Matt Evans
- [PATCH v4 09/10] vfio/pci: Permanently revoke a DMABU... Matt Evans
- [PATCH v4 10/10] vfio/pci: Add mmap() attributes to D... Matt Evans
