Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] dt-bindings: use of OS-specific driver name 'panthor' in DT node name --
commit ee6d231b5dc0544f3b9572b62d9e84b81e33eedd Author: Karunika Choo <[email protected]> dt-bindings: gpu: panthor: Document panthor-system bindings This commit introduces DT bindings for the ARM Mali 5th-Gen AM GPU's AM_SYSTEM block. It documents the compatible string, registers, interrupts, clocks, and regulators for this system node. > diff --git > a/Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml > b/Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml > new file mode 100644 > index 0000000000000..f0689bb8f05a2 > --- /dev/null > +++ b/Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml [ ... ] > +properties: > + $nodename: > + pattern: '^panthor-system@[a-f0-9]+$' [Severity: Low] Does this node name pattern violate the Device Tree specification's generic names recommendation? Device tree bindings are expected to describe the underlying hardware in an OS-agnostic manner. Since 'panthor' is the name of the Linux DRM driver rather than the hardware itself (ARM Mali 5th-Gen AM GPU's AM_SYSTEM block), should this use a generic class name like '^gpu-system@[a-f0-9]+$' or '^system-controller@[a-f0-9]+$' instead? [ ... ] > +additionalProperties: false > + > +examples: > + - | > + #include <dt-bindings/interrupt-controller/irq.h> > + #include <dt-bindings/interrupt-controller/arm-gic.h> > + > + panthor_system: panthor-system@68000000 { [Severity: Low] Similarly, this example demonstrates the OS-specific node name. Should it be updated to match a generic functional name as well? > + compatible = "arm,mali-gen5-am-system"; > + reg = <0x68000000 0x10000>; [ ... ] -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=10
