(re-posting my mail from Sep 28 because apparently I forgot Reply-all) On Sat Sep 26, 2026 at 7:30 PM IST, erebion wrote: > Adds the qcom,rmtfs-mem node required for the modem > > Signed-off-by: erebion <[email protected]> > --- > .../boot/dts/qcom/sm6350-sony-xperia-lena-pdx213.dts | 17 > +++++++++++++++++ > 1 file changed, 17 insertions(+) > > diff --git a/arch/arm64/boot/dts/qcom/sm6350-sony-xperia-lena-pdx213.dts > b/arch/arm64/boot/dts/qcom/sm6350-sony-xperia-lena-pdx213.dts > index 79aa2521aed40..0ef3e9e239786 100644 > --- a/arch/arm64/boot/dts/qcom/sm6350-sony-xperia-lena-pdx213.dts > +++ b/arch/arm64/boot/dts/qcom/sm6350-sony-xperia-lena-pdx213.dts > @@ -4,6 +4,7 @@ > */ > /dts-v1/; > > +#include <dt-bindings/firmware/qcom,scm.h> > #include <dt-bindings/leds/common.h> > #include <dt-bindings/pinctrl/qcom,pmic-gpio.h> > #include <dt-bindings/regulator/qcom,rpmh-regulator.h> > @@ -54,6 +55,22 @@ touch_en_vreg: touch-en-regulator { > > vin-supply = <&pm6350_l6>; > }; > + > + reserved-memory {
r (reserved-memory) < t (touch-en-regulator) But it'd probably make more sense to actually rename touch-en-regulator to regulator-touch-en (to keep any future fixed-regulator sorted together as well), then the current sorting makes sense. Maybe add this as a patch before this one? With that fixed: Reviewed-by: Luca Weiss <[email protected]> > + /* > + * The rmtfs memory region in downstream is 'dynamically > allocated' > + * but given the same address every time. Hard code it as this > address is > + * where the modem firmware expects it to be. > + */ > + rmtfs@fe901000 { > + compatible = "qcom,rmtfs-mem"; > + reg = <0x0 0xfe901000 0x0 0x280000>; > + no-map; > + > + qcom,client-id = <1>; > + qcom,vmid = <QCOM_SCM_VMID_MSS_MSA>; > + }; > + }; > }; > > &apps_rsc {
