Hi!
On Aug 18, 2008, at 1:34 AM, Jay Pipes wrote:
For some bool attributes, there is a is_ prefix (like is_unsigned).
For
others, like primary and key and auto_increment, there is no prefix.
Let's stick to one or the other. Personally, I prefer the is_
prefix as
it makes the resulting code more explicit and readable.
++
2) Consider an alternate format for the Field definition
message FieldOptions {
optional bool is_primary_key = 0 [default = false];
optional bool is_autoincrement = 1 [default = false];
optional bool is_key = 2 [default = false];
optional bool is_variable_width = 3;
optional string default_value = 4;
optional bool on_update = 16; /* Reserve 0 - 15 for most common */
}
Primary and unique are constraints on keys, not on Fields (the wiki is
a bit out of date). Variable Width is not an option (it is a matter
of type)
optional string character_set = 1; /* Perhaps this can go away */
This is why I brought up the UtF8 discussion again :)
* Uses 0 - 15 for most common elements. Proto Buffers has an
Thanks, I had not picked this up.
What is Field.values? Is this for the ENUM and SET (now gone?) data
types? If so, can we push this out to an EnumOptions nested
message, as
it is a bit confusing being in the main Field definition.
Ok (and yes it is for ENUM, and I suspect long term for any array
values as well).
So maybe a better name involves Array?
What is Field.custom_name?
It is gone in the current definition.
Cheers,
-Brian
--
_______________________________________________________
Brian "Krow" Aker, brian at tangent.org
Seattle, Washington
http://krow.net/ <-- Me
http://tangent.org/ <-- Software
_______________________________________________________
You can't grep a dead tree.
_______________________________________________
Mailing list: https://launchpad.net/~drizzle-discuss
Post to : [email protected]
Unsubscribe : https://launchpad.net/~drizzle-discuss
More help : https://help.launchpad.net/ListHelp