MARK CALLAGHAN wrote:
1) Why have ROWS_UPDATED instead of ROWS_INSERTED, ROWS_DELETED,
ROWS_UPDATED? I'd prefer to have more granular stats for the user, myself,
and knowing the code, it wouldn't be particularly difficult to make the
collection more granular.
I much prefer to have the data split as you describe. The port of
TABLE_STATISTICS to the Facebook MySQL patch does the same.
Cool, good to hear. :)
2) CONCURRENT_CONNECTIONS is supposed to represent the "current value" of
the number of concurrent connections this user has to the server. I think
that having an additional column containing the maximum number of concurrent
connections this user has created would be useful as well:
That would be nice to have. I was asked for it several times
internally. You need a way to reset it over time.
MAX_CONCURRENT_CONNECTIONS BIGINT NOT NULL
Computing concurrent connections per-account made the feature much
more complex. Can you avoid the complexity in the Drizzle version of
this?
Wouldn't MAX_CONCURRENT_CONNECTIONS just be a "high water mark" for the
CONCURRENT_CONNECTIONS value though?
3) ROWS_FETCHED vs TABLE_ROWS_READ. What's the difference?
ROWS_FETCHED needs a better name -- ROWS_RETURNED.
Ah, I see. So, are you suggesting that it be changed to:
ROWS_READ
ROWS_SENT
ROWS_CHANGED
?
Thanks!
Jay
_______________________________________________
Mailing list: https://launchpad.net/~drizzle-discuss
Post to : [email protected]
Unsubscribe : https://launchpad.net/~drizzle-discuss
More help : https://help.launchpad.net/ListHelp