<snip> > > > 3) ROWS_FETCHED vs TABLE_ROWS_READ. What's the difference? >>> >> >> ROWS_FETCHED needs a better name -- ROWS_RETURNED. >> > > Ah, I see. So, are you suggesting that it be changed to: > > ROWS_READ > ROWS_SENT > ROWS_CHANGED > > ROWS_CHANGED and ROWS_UPDATED seems very confusing to have in the same table
So far this is what I have for the schema based on this discussion For USER_STATISTICS changed the following Added: ROWS_INSERTED, ROWS_DELETED, MAX_CONCURRENT_CONNECTIONS Removed: BINLOG_BYTES_WRITTEN, SELECT_COMMANDS, UPDATE_COMMANDS, OTHER_COMMANDS, COMMIT_TRANSACTIONS, ROLLBACK_TRANSACTIONS, EMPTY_QUERIES CREATE TABLE INFORMATION_SCHEMA.USER_STATISTICS ( USER VARCHAR(255) NOT NULL , TOTAL_CONNECTIONS BIGINT NOT NULL , CONCURRENT_CONNECTIONS BIGINT NOT NULL , MAX_CONCURRENT_CONNECTIONS , CONNECTED_TIME BIGINT NOT NULL , BUSY_TIME BIGINT NOT NULL , CPU_TIME BIGINT NOT NULL , BYTES_RECEIVED BIGINT NOT NULL , BYTES_SENT BIGINT NOT NULL , ROWS_FETCHED BIGINT NOT NULL , ROWS_UPDATED BIGINT NOT NULL , ROWS_INSERTED , ROWS_DELETED , TABLE_ROWS_READ BIGINT NOT NULL , DENIED_CONNECTIONS BIGINT NOT NULL , LOST_CONNECTIONS BIGINT NOT NULL , ACCESS_DENIED BIGINT NOT NULL , PRIMARY KEY (USER) ); CREATE TABLE INFORMATION_SCHEMA.USER_COMMANDS ( USER VARCHAR(255) NOT NULL , COUNT_SELECT BIGINT NOT NULL , COUNT_INSERT BIGINT NOT NULL , COUNT_UPDATE BIGINT NOT NULL , COUNT_DELETE BIGINT NOT NULL , COUNT_COMMIT BIGINT NOT NULL , COUNT_ROLLBACK BIGINT NOT NULL , COUNT_CREATE BIGINT NOT NULL /* create table, schema, and index */ , COUNT_ALTER BIGINT NOT NULL /* alter table, schema, and index */ , COUNT_ADMIN BIGINT NOT NULL /* administrative commands */ , COUNT_EMPTY BIGINT NOT NULL /* empty queries... */ , PRIMARY KEY (USER) );
_______________________________________________ Mailing list: https://launchpad.net/~drizzle-discuss Post to : [email protected] Unsubscribe : https://launchpad.net/~drizzle-discuss More help : https://help.launchpad.net/ListHelp

