Dear EasyBuilders,

You may not believe it, but we have found a way to make the just released EasyBuild v3.5.2 even better. Actually, it wasn't that hard, since we accidentally broke --new-pr in that last release.


So, I'm happy to announce the release of EasyBuild version 3.5.3 [1].
With the above in mind, there's no doubt this is the best EasyBuild release to date!

Highlights include:

    * fixed target account for branch pushed when using --new-pr

    * enhanced custom easyblocks for GROMACS & Gurobi

    * support for 2 new software packages: CNVkit, hmmlearn

    * updates for already supported software, incl. matplotlib 2.1.2 and TensorFlow 1.6.0

    * hard disabled UCX support for recent OpenMPI versions, to dance around bug in OpenMPI configure script

    * some additional minor bug fixes & enhancements

This brings the total number of supported software packages to 1,398 [2]!
A detailed overview of all changes is available in the release notes [3].

Thanks to everyone who contributed to this release in one way or another!


To upgrade to EasyBuild v3.5.3, there are several options, see [4].
Two particularly easy options include:

    * eb --install-latest-eb-release  # requires EasyBuild v3.3.0 or more recent

    * eb --from-pr 5968                  # use easyconfig from PR #5968 [5]

(EasyBuild v3.3.0 is required for --install-latest-eb-release because support for SHA256 checksums is required)


Enjoy!

regards,

Kenneth (a.k.a. boegel)
EasyBuild release manager


[1] https://pypi.python.org/pypi/easybuild/3.5.3
[2] http://easybuild.readthedocs.io/en/latest/version-specific/Supported_software.html
[3] http://easybuild.readthedocs.io/en/latest/Release_notes.html
[4] http://easybuild.readthedocs.io/en/latest/Installation.html#updating-an-existing-easybuild-installation
[5] https://github.com/easybuilders/easybuild-easyconfigs/pull/5968/files

Reply via email to