Recently, I wanted to link to the documentation of -remote in the
ELinks manual.  That is currently at
but the chapter number may change as the manual is edited.
To make such links more reliable in the future, I'd like to
change the file names now to more descriptive ones: for example,
this one could be remote.html.

By changing the xmlto invocation in doc/Makefile to

> %.html-chunked: %.xml
>       $(call cmd,xmlto,--stringparam html)

and then changing the beginning of doc/remote.txt to

> [[remote]]
> Managing remote ELinks instances
> --------------------------------

I get the remote.html file, as desired.

Now then, the other files.  Subsection 1.7 (Feature configuration file)
comes from $builddir/doc/features.txt, which begins with:

> [[features.conf]]
> Feature configuration file (`features.conf`)
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

It appears that AsciiDoc 7.1.2 (bundled in elinks-0.12) does not
allow "features.conf" as a BlockId; the section element in the
generated manual.xml does not get any id attribute, and the file
is consequently not called features.conf.html.  The problem seems
to be in doc/tools/asciidoc/asciidoc.conf, which does not allow
dots in a bare ID:

> attributelist-pattern=(?u)(^\[\[(?P<id>[\w\-_]+)\]\]$)|(^\[(?P<attrlist>.*)\]$)

If I change conf2doc to generate [id="features.conf"], then it works.
It currently does this:

> label="[[$(echo $config_name | sed 's/_/-/g')]]"

Does anyone remember what exactly was the reason for replacing
underscores with hyphen-minuses?  The change was made on
2005-05-18: "Fix config labels to make pdf building work
(s/CONFIG_FOO/CONFIG-FOO/)."  However, I just tried building a
PDF with underscores and had no problems; links worked too.

Attachment: pgp80QZJi3aVC.pgp
Description: PGP signature

elinks-dev mailing list

Reply via email to