I believe filter is a pretty standard name for this. Even Javascript has Array.filter <https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/filter> with the same semantics.
In .NET Linq uses `.Where`, but I believe that is mainly to have similarity with SQL. On Tuesday, October 18, 2016 at 2:35:45 PM UTC-5, Duane Johnson wrote: > > I saw @_chunglou's tweet > <https://twitter.com/_chenglou/status/788165827560214528> yesterday and > wondered if this had been discussed before: > > "I can never, ever remember whether `filter` needs `true` or `false`. > `keep` would be a nicer name." > > I agree `keep` would remove the ambiguity. Thoughts? > > -- Duane > > > -- You received this message because you are subscribed to the Google Groups "Elm Discuss" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. For more options, visit https://groups.google.com/d/optout.
