Recently, I ran into a problem compiling org-mode asynchronously with
each .el file being compiled in a separate process (via
When I tried to compile org-refile.el in a separate Emacs process
(without compiling all other .el files), there was no way for the
byte-compiler to know that org-with-wide-buffer is a macro.

As I understand, normally org-mode compiles synchronously with all the
.el files being byte-compiled in alphabetic order. Then,
(eval-and-compile (require 'org-macs)) from org.el is defined prior
compiling all the org-*.el files, which accidentally allow the org-mode
to be compiled without any issues.

Note that I first reported this to bug-gnu-emacs mail-list [1], but it
seems that absence of (require 'org-macs) is wrong on the org-mode side.

Let me know what you think.



Emacs  : GNU Emacs 28.0.50 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.13, 
cairo version 1.16.0)
 of 2020-04-01
Package: Org mode version 9.3.6 (release_9.3.6-441-gba6855 @ 
Ihor Radchenko,
Center for Advancing Materials Performance from the Nanoscale (CAMP-nano)
State Key Laboratory for Mechanical Behavior of Materials, Xi'an Jiaotong 
University, Xi'an, China

Reply via email to