Nathan Neff <> writes:
> Some time ago, I set up a blog using org-jekyll.  I recently tried
> to publish my blog, but when I run:
> org-jekyll-export-blog
> I get the message:  Symbol's function definition is void:
> org-publish-initialize-files-alist
> I grepped for this function, and noticed that it is now defined in
> org-protocol.el
> using (declare-function org-publish-initilialize-files-alist "org-publish"),
> whereas before, the function was declared in org-publish.el
> Can anyone help with this problem?
> I tried putting this in my emacs, but it didn't work:
> (require 'org-protocol.el)
> (require 'org-publish)
> (require 'org-jekyll)

Hi Nathan,

glad you pointed out this one.

No, that function does not exist anymore!

It is still declared in org-protocol.el but that's obsolete.  I'll have
to remove that from org-protocol.el.

The list of files in a project is now stored as elisp code in cache
files. You can find all the functions in questions by either searching
`(defun org-publish-cache' in org-publish.el, or simply doing

    C-h f org-publish-cache TAB TAB

Best wishes


Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.

Reply via email to