Nathan Neff <> writes:
> Some time ago, I set up a blog using org-jekyll.  I recently tried
> to publish my blog, but when I run:
> org-jekyll-export-blog
> I get the message:  Symbol's function definition is void:
> org-publish-initialize-files-alist
> I grepped for this function, and noticed that it is now defined in
> org-protocol.el
> using (declare-function org-publish-initilialize-files-alist "org-publish"),
> whereas before, the function was declared in org-publish.el
> Can anyone help with this problem?
> I tried putting this in my emacs, but it didn't work:
> (require 'org-protocol.el)
> (require 'org-publish)
> (require 'org-jekyll)
> Thanks,
> --Nate


I cannot find a file named org-jekyll.el or similar.

But I guess `org-publish-initialize-files-alist' is just called to find
a project the current files belongs to.
If that is the case, you simply remove the call to that function and use

  (let ((project
         (org-publish-get-project-from-filename buffer-file-name)))

If you encounter any problems, I'll be glad to help.


Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.

Reply via email to