Hi,

Indeed on later reading I see it was lacking in detail so I followed up
later.

It’s unclear if, following rasters last email, he is still in agreement
with the _count() change but it seems like an improvement so I intend to go
forward with it as discussed.

Thanks,
Andy
On Tue, 7 Nov 2017 at 13:57, Mike Blumenkrantz <
michael.blumenkra...@gmail.com> wrote:

> In this case I would agree with raster; the original mail could have
> provided a little more detail because it is non-obvious to the reader why
> this could be misleading for users.
>
> efl_ref_count() is in line with the rest of our naming (e.g.,
> eina_array_count(), eina_list_count(), eina_hash_population(), etc) and
> seems like a clear improvement. Nice work.
>
> On Tue, Nov 7, 2017 at 7:41 AM Carsten Haitzler <ras...@rasterman.com>
> wrote:
>
> > On Mon, 06 Nov 2017 09:53:32 +0000 Andrew Williams <a...@andywilliams.me
> >
> > said:
> >
> > > Can you please explain why? This is a method that returns a count of
> > > references but has no mention of count in the name.
> >
> > Well your original email gave no details as to why it's misleading. I
> > disagree
> > because i see something like:
> >
> > Eo   *efl_ref(Eo *obj);
> > int   efl_ref_get(Eo *obj);
> > void  efl_unref(Eo *obj);
> > ...
> >
> > i.e. the context of the api, and to me it screams of "ref is reference or
> > references" and since there is something to ref and unref already ref_get
> > returning an int obviously is returning a reference count (to me). since
> > i'm
> > familiar with reference counting techniques in general (nothing to do
> with
> > the
> > code implementation or api here), to me it's obvious that this returns
> the
> > reference count (an integer) and it's short form for that.
> >
> > if i saw this api in glib or gtk or libjpeg or libpng or zlib or any
> other
> > library i'd think the same with zero documentation and just api
> signatures
> > like
> > the above.
> >
> > i've learned api's by just reading .h files (like xlib) and seeing this
> and
> > taking a guess as to what it means. an int generally to me indicates it's
> > returning a number as opposed to something opaque in higher level libs
> like
> > efl/gtk etc.. it has meaning. libc calls return ints and are different as
> > they
> > tend to mean an error or success, but look at glib or gtk or others and
> > they
> > dont do this and efl doesn't do the libc thing either as a whole.
> >
> > so given the context as a whole and as a sub-part of the api like
> above...
> > i
> > disagree that its misleading. to me its pretty obvious. maybe because
> i've
> > spent a lot of time with various api's and so on i tend to fill in the
> > blanks
> > quickly seeing this kind of information. i don't know.
> >
> > but if you think it's misleading can you give more information? why is it
> > misleading? what is it leading you to think it is and why is that? what
> is
> > the
> > difference in view point or experience and how conclusions are being
> > attained?
> >
> > > We have ref_add and wref_add that are talking about actual references
> but
> > > ref_get returns a count?
> > > This is misleading.
> > >
> > > Andy
> > >
> > > On Mon, 6 Nov 2017 at 09:49 Carsten Haitzler <ras...@rasterman.com>
> > wrote:
> > >
> > > > On Mon, 06 Nov 2017 09:46:41 +0000 Andrew Williams <
> > a...@andywilliams.me>
> > > > said:
> > > >
> > > > i'd have to disagree on it being misleading... :/
> > > >
> > > > > Hi,
> > > > >
> > > > > Whilst writing the docs we have realised that efl_ref_get is a
> > slightly
> > > > > misleading method name as it returns the reference count. Whilst we
> > are
> > > > > breaking APIs for our first interfaces release would people mind me
> > > > > changing efl_ref_get to efl_refcount_get (as per this eo patch, and
> > all
> > > > the
> > > > > efl ramifications).
> > > > >
> > > > > I'd prefer not to leave the old method in place but could do so if
> > you
> > > > > think there is a big problem making this breaking change?
> > > > >
> > > > > Thanks :)
> > > > > Andy
> > > > >
> > > > >
> > > > > --
> > > > > http://andywilliams.me
> > > > > http://ajwillia.ms
> > > >
> > > >
> > > > --
> > > > ------------- Codito, ergo sum - "I code, therefore I am"
> > --------------
> > > > Carsten Haitzler - ras...@rasterman.com
> > > >
> > > > --
> > > http://andywilliams.me
> > > http://ajwillia.ms
> > >
> >
> ------------------------------------------------------------------------------
> > > Check out the vibrant tech community on one of the world's most
> > > engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> > > _______________________________________________
> > > enlightenment-devel mailing list
> > > enlightenment-devel@lists.sourceforge.net
> > > https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> > >
> >
> >
> > --
> > ------------- Codito, ergo sum - "I code, therefore I am" --------------
> > Carsten Haitzler - ras...@rasterman.com
> >
> >
> >
> >
> ------------------------------------------------------------------------------
> > Check out the vibrant tech community on one of the world's most
> > engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> > _______________________________________________
> > enlightenment-devel mailing list
> > enlightenment-devel@lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> >
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> enlightenment-devel mailing list
> enlightenment-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
>
-- 
http://andywilliams.me
http://ajwillia.ms
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to