On Sun, 07 Aug 2011 00:37:06 +0900 Jiyoun Park <jy0703.p...@samsung.com> said:

need:

for elm:

1. docs: need more documentation with more description and details as
well as examples of how to use the api calls
2. should add a test to elm_test to show off how it works and be able to test
that it works.

for evas: need more documentation with more description and details as
well as examples of how to use the api calls

1. docs: 

that's actually it! just docs and test for elm! :)


> I rename elementary API.
> 
> Below is API names. 
> 
> <Evas>
> Eina_Bool evas_object_image_animated_get (const Evas_Object *obj) 
> int evas_object_image_animated_frame_count_get (const Evas_Object *obj) 
> Evas_Image_Animated_Loop_Hint evas_object_image_animated_loop_type_get(const
> Evas_Object *obj) int evas_object_image_animated_loop_count_get (const
> Evas_Object *obj) double evas_object_image_animated_frame_duration_get (const
> Evas_Object *obj, int start_frame, int fram_num) void
> evas_object_image_animated_frame_set (Evas_Object *obj, int frame_num) 
> 
> <Elementary>
> Eina_Bool elm_icon_animated_available_get (const Evas_Object *obj) 
> Void elm_icon_animated_set (Evas_Object *obj, Eina_Bool anim) 
> Eina_Bool elm_icon_animated_get (const Evas_Object *obj) void 
> elm_icon_animated_play_set (Evas_Object *obj, Eina_Bool play) Eina_Bool 
> elm_icon_animated_play_get (const Evas_Object *obj) Todo 1. optimization
> 
> 
> 
> 1. You are right. Document is really needed for application developer.
>     I already have test application. Which file can I add to example code? 
> 2. I modified evas_image_load_gif file.
> 3. I add null to generic, eet, psd, svg, and xpm
> 
> Thanks.
> 
> -----Original Message-----
> From: Carsten Haitzler (The Rasterman) [mailto:ras...@rasterman.com] 
> Sent: Friday, July 29, 2011 8:12 PM
> To: Jiyoun Park
> Cc: 'Daniel Juyung Seo'; 'ChunEon Park';
> enlightenment-devel@lists.sourceforge.net Subject: Re: [E-devel] [Patch]
> Animation gif feature patch
> 
> On Tue, 26 Jul 2011 16:25:45 +0900 Jiyoun Park <jy0703.p...@samsung.com> said:
> 
> i see chuneon's point. evas uses "animated" and elm "anim". so either use
> animated or anim in both - i'd choose animated. :) can you just rename the
> elm calls and resend the patches?
> 
> i'll review them apart from the name thing here:
> 
> 1. documentation - way too little WAAAAAAAAAAAAAY too little. provide
> examples of the functions and how to use them in a small app 
> 
> 2.static Eina_Bool _evas_image_... and static Eina_Bool
> _evas_image_load_frame_... and static Eina_Bool _evas_image_load_fram... why
> no newline between retyurn type and function name? the other functions have
> it.... static Eina_Bool evas_image_load_file_data... too 
> 
> 3. you missed adding NULL to the generic, eet, psd, svg, and xpm loader
> structs i believe. (like you did to the others).
> 
> :) can you fix the naming and the above and re-send the patches? :)
> 
> > 1. why do you think *_animated_* is not proper name?
> > long character or grammar problem (word class? Other reason?) ?
> > *_animated_* is familiar to me, and there is no place related with 
> > this in evas , so I want to keep this name. But If this name is wrong  
> > or not acceptable name generally , I will consider to change API name.
> > 2. yes . I already have elm_icon_anim_available_get API 3. 
> > elm_icon_anim_set means I will use animation mode currently or later.
> >     Elm_icon_anim_play_set is for real play of image.
> > 
> > Thanks.
> > 
> > -----Original Message-----
> > From: Daniel Juyung Seo [mailto:seojuyu...@gmail.com]
> > Sent: Monday, July 25, 2011 11:43 PM
> > To: ChunEon Park
> > Cc: Jiyoun Park; enlightenment-devel@lists.sourceforge.net
> > Subject: Re: [E-devel] [Patch] Animation gif feature patch
> > 
> > 1)
> > > Frankely, I don't like *_animated_*
> > Agreed. Choose either animation or anim and apply it to 
> > evas_object_image and elm_icon. I prefer anim :)
> > 
> > 2)
> > > Eina_Bool elm_icon_anim_get (const Evas_Object *obj)
> > > -> elm_icon_anim_available_get ...
> > elm_icon_anim_available_get is already in Jiyoun's patch.
> > 
> > 3)
> > API names are not clear. For me 2 names are confusing.
> > elm_icon_anim_set()
> > elm_icon_anim_play_set()
> > What's anim mode and anim play mode? Maybe I'm missing some animation 
> > image concept.
> > 
> > Thanks.
> > Daniel Juyung Seo (SeoZ)
> > 
> > 
> > 
> > On Mon, Jul 25, 2011 at 8:20 PM, ChunEon Park <her...@naver.com> wrote:
> > > Frankely, I don't like *_animated_*
> > > How about just animation or anim?
> > > evas_object_image_animation_available_get
> > > evas_object_image_animation_frame_get
> > > ...
> > > and this API also.
> > > Eina_Bool elm_icon_anim_get (const Evas_Object *obj)
> > > -> elm_icon_anim_available_get ...
> > > ------------------------------------
> > > Let's run together for the best moment!
> > >  -Regards, Hermet-
> > >
> > > -----Original Message-----
> > > From: "Jiyoun Park"&lt;jy0703.p...@samsung.com&gt;
> > > To: enlightenment-devel@lists.sourceforge.net
> > > Cc:
> > > Sent: 11-07-25(월) 17:18:22
> > > Subject: [E-devel] [Patch] Animation gif feature patchHello.
> > > I modified animated gif feature code according Mike’s advise.
> > > Added api
> > > Eina_Bool evas_object_image_animated_get (const Evas_Object *obj) 
> > > int evas_object_image_animated_frame_num_get (const Evas_Object 
> > > *obj) Evas_Image_Animated_Loop_Hint 
> > > evas_object_image_animated_loop_type_get
> > > (const Evas_Object *obj)
> > > int evas_object_image_animated_loop_count_get (const Evas_Object 
> > > *obj) double evas_object_image_animated_frame_duration_get (const 
> > > Evas_Object *obj, int start_frame, int fram_num) void 
> > > evas_object_image_animated_frame_set (Evas_Object *obj, int 
> > > frame_num) Eina_Bool elm_icon_anim_available_get (const Evas_Object 
> > > *obj) Void elm_icon_anim_set (Evas_Object *obj, Eina_Bool anim) 
> > > Eina_Bool elm_icon_anim_get (const Evas_Object *obj) void 
> > > elm_icon_anim_play_set (Evas_Object *obj, Eina_Bool play) Eina_Bool 
> > > elm_icon_anim_play_get (const Evas_Object *obj) Todo 1. optimization 
> > > 2. Test case to test several files Test_icon.c is for elm icon test.
> > > Change test_icon.c in elementary/src/bin to this.
> > > Thanks.
> > > ----------------------------------------------
> > > Jiyoun Park
> > >
> > > Mobile S/W Platform Lab
> > > DMC R&D Center
> > > SAMSUNG ELECTRONICS CO. ,LTD
> > >
> > > TEL: +82-31-279-0619
> > > Mobile: +82-10-9871-0703
> > > jy0703.p...@samsung.com
> > > ----------------------------------------------
> > > --------------------------------------------------------------------
> > > --
> > > --------
> > > Storage Efficiency Calculator
> > > This modeling tool is based on patent-pending intellectual property 
> > > that has been used successfully in hundreds of IBM storage 
> > > optimization engage- ments, worldwide.  Store less, Store more with 
> > > what you own, Move data to the right place. Try It Now!
> > > http://www.accelacomm.com/jaw/sfnl/114/51427378/
> > > _______________________________________________
> > > enlightenment-devel mailing list
> > > enlightenment-devel@lists.sourceforge.net
> > > https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> > >
> > 
> > 
> > ----------------------------------------------------------------------
> > -------- Magic Quadrant for Content-Aware Data Loss Prevention 
> > Research study explores the data loss prevention market. Includes 
> > in-depth analysis on the changes within the DLP market, and the 
> > criteria used to evaluate the strengths and weaknesses of these DLP
> > solutions. http://www.accelacomm.com/jaw/sfnl/114/51385063/
> > _______________________________________________
> > enlightenment-devel mailing list
> > enlightenment-devel@lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> 
> 
> --
> ------------- Codito, ergo sum - "I code, therefore I am" --------------
> The Rasterman (Carsten Haitzler)    ras...@rasterman.com


-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    ras...@rasterman.com


------------------------------------------------------------------------------
BlackBerry&reg; DevCon Americas, Oct. 18-20, San Francisco, CA
The must-attend event for mobile developers. Connect with experts. 
Get tools for creating Super Apps. See the latest technologies.
Sessions, hands-on labs, demos & much more. Register early & save!
http://p.sf.net/sfu/rim-blackberry-1
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to