On Monday, 24 September 2018 06:34:35 BST Simon Lees wrote:
> On 18/09/2018 23:59, Mick wrote:
> > On Tuesday, 18 September 2018 11:27:35 BST sergio wrote:
> >> On 18/09/2018 11:31, Mick wrote:
> >>> Where are QT_QPA_PLATFORMTHEME and QT_STYLE_OVERRIDE specified outside
> >>> the
> >>> GUI?  In ~/.bashrc?  Where could they be set for system wide settings?
> >> 
> >> QT_STYLE_OVERRIDE is not specified.
> >> 
> >> QT_QPA_PLATFORMTHEME is from /etc/X11/Xsession.d/99qt5ct, which rewrites
> > 
> >> nothing, and just adds:
> > OK, this file is not installed in gentoo.
> > 
> >> moreover, there is ~/.xsession for user settings
> > 
> > I tried unsetting $QT_STYLE_OVERRIDE in ~.xsession, but I still got gtk2.
> > Then, set it to a blank value using e's Settings/Advanced/Environment
> > Variables and this time it took.  However, I'm still no closer to having
> > KDE applications launching with QT themes and icons, unless I launch them
> > from within urxvt.
> Setting it from enlightenment's environment variable section should
> work, the way its implemented at the moment is the least worst way we
> could come up with to not have all users Qt apps broken by default.

Yes, setting $QT_STYLE_OVERRIDE to a blank value using e's Settings/Advanced/
Environment Variables works in clearing the default gtk2 value.

Adding the contents of the /etc/X11/Xsession.d/99qt5ct file Sergio mentioned 
also works in defining $QT_QPA_PLATFORMTHEME as qt5ct.

What doesn't work is starting any KDE application and having it load the Qt 
theme I have selected.  The only exception seems to be when I launch a KDE 
application from within urxvt, whereby the Qt theme is respected and loads as 

The urxvt terminal output where Qt theme works is this:

$ kwrite
qt5ct: using qt5ct plugin
QApplication: invalid style override passed, ignoring it.
qt5ct: D-Bus global menu: no
QXcbConnection: XCB error: 5 (BadAtom), sequence: 955, resource id: 0, major 
code: 19 (DeleteProperty), minor code: 0

While the terminology/xterm output where Qt theme is ignored is this:

$ kwrite
QApplication: invalid style override passed, ignoring it.

enlightenment-users mailing list

Reply via email to