Hi all.

I'm on a new laptop & build ( git ) and all the "System Actions":
 - Suspend
 - Hibernate
 - Power Off
 - Reboot
  ... are disabled.

I've built with systemd support:

EFL is configured with:

./autogen.sh \
 --prefix=/opt/e22 \
 --enable-harfbuzz \
 --enable-drm \
 --enable-gl-drm \
 --enable-wayland \
 --enable-systemd \
 --enable-egl \
 --with-opengl=es \
 --enable-xinput22 \
 --enable-elput \

Enlightenment is configured with:

meson configure build \
 -Dprefix=/opt/e22 \
 -Dincludedir=/opt/e22 \
 -Dwayland=True \
 -Dsystemd=True \
 -Dbuildtype=release \
 -Ddebug=False \

I noticed that the generated sysactions.conf was incorrect:

action:   halt           /usr/bin/systemctl poweroff
action:   reboot         /usr/bin/systemctl reboot
action:   suspend        /usr/bin/systemctl suspend
action:   hibernate      /usr/bin/systemctl hibernate

My systemctl is /bin/systemctl. I first tried updating the installed
sysactions.conf and entering the correct path ( and restating E ) to
systemctl - but this had no effect. I've also tried sym-linking
/usr/bin/systemctl to /bin/systemctl ( and restarting E ) - this also has
no effect.

I'm running out of ideas :) Anyone?


enlightenment-users mailing list

Reply via email to