On Sep 7, 2010, at 9:34 AM, Ash Berlin wrote: > On 7 Sep 2010, at 17:18, P T Withington wrote: >> On 2010-09-07, at 12:02, Brendan Eich wrote: >> >>> 3. identical >> >> If I had a vote, +1 >> >> Is there someplace that concisely explains the cost of just fixing `===` so >> I could understand why that is not a choice? >> > > FWIW this sort of naming issue is a rabbit hole that CommonJS fell down when > it came to method names for a unit test framework[0]. There was no real > consensus, but we settled on equal meaning == and strictEqual meaning ===.
Those are fine names, and it seems you came out of the rabbit hole (under the bikeshed ;-). All naming discussions can rathole (let's say), but I hope we can conclude this thread with a clear winner, as it seems you guys ultimately did. Also, you picked spec-like names for == and === but there is no SameValue or Object.eq, I take it (even though one can be written in JS). If you had such a thing, I wonder whether you wouldn't name it identical (not reallyStrictEqual or sameValue). But I don't want to send you back down the hole to find out! This es-discuss hole will do. /be _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

