I'd agree with using clear() and isEmpty() with their respective actions. On Wed, Feb 15, 2012 at 00:37, Brendan Eich <[email protected]> wrote: > Good idea, but I suggest an unambiguous verb instead of an > adjective-or-verb: clear. > > "empty" is often used for the predicate, in naming conventions that eschew > "isEmpty" and "emptyp" patterns. > > /be > > > Peter Michaux wrote: >> >> If some piece of code needs to empty a set, it would be good to do >> that in a single call >> >> set.empty(); >> >> Otherwise we might be left doing the following which could be very >> inefficient. >> >> set.forEach(function(element) { >> set['delete'](element); >> }); >> >> Peter >> _______________________________________________ >> es-discuss mailing list >> [email protected] >> https://mail.mozilla.org/listinfo/es-discuss >> > _______________________________________________ > es-discuss mailing list > [email protected] > https://mail.mozilla.org/listinfo/es-discuss
-- Adam Shannon Developer University of Northern Iowa Sophomore -- Computer Science B.S. & Mathematics http://ashannon.us _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

