On Jul 12, 2013, at 3:54 PM, Jeff Walden wrote: > On 07/12/2013 10:27 AM, Tab Atkins Jr. wrote: >> And, because of what we discussed in the recent thread... >> >> Number.isInteger(Math.pow(2,53)-1) == true >> Number.isInteger(Math.pow(2,53)) == false > > I need to comment in the other thread again and push back against what people > have said there, but that thread's issues aside entirely, this is very very > wrong. 2**53 is an integer. That there are multiple mathematical integer > values that, when converted to IEEE-754 format, are equal to 2**53 is > irrelevant. An integer value, that operations claim is not an integer, is > very very wat.
are you suggesting that if we want such an function, it should be named something else, such as isExactInteger, isPreciseInteger, isUnambiguousInteger, etc? Allen _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

