On 07/12/2013 04:56 PM, Allen Wirfs-Brock wrote: > So you seem to be saying that that > Number.isInteger(MAX_VALUE) should be true, but that Number.MAX_VALUE > > Number.MAX_INTEGER is also true because for isInteger you using the > mathematical definition of "Integer" but for MAX_INTEGER you are using some > other definition of "INTEGER".
I think so. Although, I am not at all wedded to the MAX_INTEGER name, it's just what was proposed already. :-) Your implied point is well-taken that "max integer" is a misnomer. MAX_EXACT_INTEGER, perhaps? Maybe? I dunno. There surely must be some API with prior art for a name here, but I can't immediately find it in web searches right now. Jeff _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

