I don't think you'll want to have divergent behavior for construct vs. call with new APIs. I believe that would go against Allen's approach for new ES6 built in classes, and beyond that, it unnecessarily overloads the API surface. Different operations ought to have different names.
{ Kevin }
_______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

