On Mon, Aug 26, 2013 at 7:47 AM, Mark Miller <[email protected]> wrote: > If we do call the coercer Promise.from, as should rename the acceptor > Promise.accept rather than Promise.of. If we want an Array coercer rather > than an Array copier, we should consider renaming Array.from to Array.as.
I oppose naming the "just wrap it in a promise" operation to .accept() - it has identical semantics to the existing Array#of(), because they're both monadic lifters, and the op should be named generically enough to work for more than just these two monads as well. > Although seemingly silly, I actually make the above argument in all > seriousness. As Brendan says "notation is user interface." In user interface > design, path-of-least-resistance matters. I agree that naming is important. I'm fine with whatever here. ~TJ _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

