Couldn't a slight variation be used for arrow functions, rather than adding yet another character in front or behind it? For example, using -> or ~> (unless they have been reserved for something in ES7):
var arrowFunction = (a, b) => a+b; var generator = (a, b) -> yield a; yield b; var async = (a, b) ~> (await a) + (await b); Marius Gundersen On Thu, Dec 12, 2013 at 11:49 AM, Forbes Lindesay <[email protected]>wrote: > I always want the * to be mandatory for full generator functions as a > visual cue. I suspect I would want something similar for async functions > but I can see logic to not needing the same visual cue on an arrow function. > > Arrow functions would often be significantly shorter, so the visual cue of > the `yield`/`await` keyword would be more obvious. > _______________________________________________ > es-discuss mailing list > [email protected] > https://mail.mozilla.org/listinfo/es-discuss >
_______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

