On Sun, Dec 22, 2013 at 10:18 AM, Kevin Smith <[email protected]> wrote:
> In KeyKOS we used the word "name". We had another meaning for the word
>> "key" and wanted to avoid confusion.
>
>
> "Name" is good.
>
> Symbol.name(Symbol.for("foo")) === "foo";
>
> Or some variant thereof.
>
I like this, but it interferes with the name property that all function
objects haveāthe Symbol.name property would no longer have the expected
value "Symbol".
Rick
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss