A Range type seems to me clearer, more powerful, and less magical.  Even
without syntax, the clarity seems better:

//for-of syntaxfor (const i of Range.upto(5)){
  //do something with i
}


for(const i of Range.from(3, 15)){
  //do something with i
}


Whether Range's are a class or it's just a set of iterator constructors
depends on what else you can do with it. The larger proposed change does
not seem to me like it offsets the confusion introduced by magical syntax
(e.g., what is the result of new Array(4)?)



On Sun, Feb 26, 2017 at 11:00 AM, John Henry <j...@iamjohnhenry.com> wrote:

> Howdy!,
>
> My name is John and I have a (hopefully non-contentious) addition for the
> ECMA Script Language described here: https://github.com/
> johnhenry/make-numbers-iterable. I wonder if there are good folks out
> there willing to give me feedback? I also wonder if someone might be
> willing to champion the proposal as described here:
> https://github.com/tc39/proposals/blob/master/CONTRIBUTING.md
>
> Thanks,
> -- John
>
> _______________________________________________
> es-discuss mailing list
> es-discuss@mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>
>
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to