On Jun 6, 2007, at 2:25 AM, Sankar P wrote:

>> I managed to get evolution 2.10.0 mostly working on Mac OS X.
>
> Congrats. Once you are done with the build try to make an installer so
> that everyone can use.

Thanks!

Yes, in-fact I am building a stand-alone application that does not  
even need an installer - you just drag the icon where you want and  
double-click it to start using it...

>>
>> Note that here on Mac OS X I had to build "libevolution-mail.so" and
>> "libevolution-calendar.so" as a dynamic library (.dylib) file instead
>> of shared object (.so) to get things linked. The .so objects are also
>> needed, but I had to create .dylibs for LD to be happy. Generally Mac
>> OS X does not like linking to a .so...
>>
>> But, I now have missing icons, and no errors are being reported
>> regarding the missing icons. In previous build attempts, I was also
>> missing icons and a was getting an error about hicolor not being
>> located (I no longer have the exact message, and I determined that
>> there was a problem with my libpixbufloader).  I then rebuilt my
>> entire GNOME/GTK and now I do not get any errors, but to my surprise
>> the icons are still missing.
>>
>> Note that Gnumeric (1.6.3) built on the same GNOME/GTK build does not
>> have any missing icons, and appears normal.
>
> oh, Wait! I faced this while I built evo on mac.
>
> Try setting XDG_DATA_DIRS to your share folder. It should solve the
> issue.

Interesting. When I set 'XDG_DATA_DIRS' to my share directory I get  
no errors, and if I set it to anything else I get the hicolor message:

(evolution-2.10:18670): Gtk-WARNING **: Could not find the icon  
'stock_mail'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
         http://icon-theme.freedesktop.org/releases


> Also, check if you have installed your hicolor or some theme. If you
> launch gnome-theme-manager once and then start Evolution it should  
> show
> all the icons.

I have in my share/icons dir:

drwxr-xr-x   10 jeshua  jeshua   340 Apr 24 01:25 gnome
drwxr-xr-x   16 jeshua  jeshua   544 Jun  6 02:23 hicolor

And in my share/themes dir I have:

drwxr-xr-x   4 jeshua  jeshua  136 Jun  2 21:57 Default
drwxr-xr-x   3 jeshua  jeshua  102 Jun  2 21:57 Emacs
drwxr-xr-x   3 jeshua  jeshua  102 Jun  2 21:57 Raleigh


I guess I will try installing the 'gnome-theme-manager' next...


Thanks again,

Jeshua Lacock, Owner
<http://OpenOSX.com>
phone: 877.240.1364



_______________________________________________
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to