Hello,

During today's round of jhbuilding I noticed that the gnome-3-0 branch of e-d-s currently fails to build. The reason is a backport of a fix for bug #645783 [1] which relies on the sealing of CamelService done in master. I have attached a (hopefully correct) patch which fixes the problem.

Regards,
Denis Washington

[1] http://git.gnome.org/browse/evolution-data-server/commit/?h=gnome-3-0&id=0db09cf5193608cc79f04f38db9b848a0ba03fe0
diff --git a/camel/camel-service.c b/camel/camel-service.c
index b922e47..8e19cff 100644
--- a/camel/camel-service.c
+++ b/camel/camel-service.c
@@ -138,7 +138,6 @@ service_get_path (CamelService *service)
         * current set of services.
         */
 
-       gpath = g_string_new (service->provider->protocol);
        if (CAMEL_PROVIDER_ALLOWS (prov, CAMEL_URL_PART_USER)) {
                use_path1 = g_string_new ("");
 
@@ -202,7 +201,7 @@ service_get_path (CamelService *service)
                use_path2 = NULL;
        }
 
-       ret_path = g_build_filename (service->priv->provider->protocol, 
use_path1 ? use_path1->str : NULL, use_path2 ? use_path2->str : NULL, NULL);
+       ret_path = g_build_filename (service->provider->protocol, use_path1 ? 
use_path1->str : NULL, use_path2 ? use_path2->str : NULL, NULL);
 
        if (use_path1)
                g_string_free (use_path1, TRUE);
_______________________________________________
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to